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Tarbimiste lisamine shapefile baasil (WaterGEMS)  
 
Ülesande püstitus 
Selles näites impordid sa WaterGEMS mudelisse tarbimise info kahest erinevast allikast, mis 
sisaldavad ka shapefile andmestikku. Esmalt kasutad sa klientide mõõdetud andmeid. Teise 
andmestikuna kasutad polügoonile lisatud inimeste arvu. Samuti arvestad sa mõõtmata 
tarbimistega (sh lekked) kokku 15%. 
 

Peale selle näite läbimist oskad sa: 

• Valida kõige sobivamat meetodit, kuidas süsteemi tarbimisi sisestada ning kust peaks 
see info ka kätte saadav olema 

• Selgitad enesele mudeli keerukamaid loomise võimalusi 

Sul on olemas veevõrgumudel, kuid sellesse pole sisestatud tarbimisi. Info mõõdetud tarbijate 
kohta eksisteerib Esri Shapefile: Meters.shp failis. Elanike andmed on Esri Shapefile: 
PopulationCensus.shp failis. 

• Käivita WaterGEMS tarkvara 
• Riba pealt: File > Open 
• Ava fail \LoadBuilder kataloogist: TarbimisteLisamineShapefile.wtg. 

 

• Vali riba pealt: View > Backgrounds, et kuvada dialoog Background Layers. 
• Kliki New nupul ning vali New File. 
• Vali fail \LoadBuilder\Meters.shp ning kliki Open. 
• Dialoogis Background Properties for Esri Shapefile vali esmalt Line Color sektsioonis 

mõni muu värv (mitte must). Saad seda muuta läbi vastava nupul klikkides. 
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Märkus: Meil on valitud värviks oranž. 

• Kliki OK, et lõpetada import. 

 

• Vali menüüst Edit > Find Element. 
• Properties dialoogis sisesta otsingukasti PMP-1 ning kliki Find nupul. 

Märkus: Suurendatakse elemendi juurde ning kuvatakse selle omadused. 

• Kontrolli/sisesta kõrgusmärgiks: Elevation (m) = 813.82. 
• Kontrolli/sisesta alljärgnevatele elementidele kõrgusmärgid nii nagu tegid eelmisega. 

Kasuta selleks FlexTable: Junction tabelit. 

Element Elevation (m) 
J-104 792.48 
J-108 813.82 
J-112 792.48 
J-113 792.48 

 
• Vali menüüst Analysis > Alternatives ning laienda sektsiooni Demand. 

Märkus: Pane tähele, et hetkel on vaid üks, vaikimisi alternatiiv nimetusega Base-Average 
Daily. 
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• Arvuta stsenaarium Base. 
• Sulge dialoog Calculation Summary ning ava FlexTable: Junction dialoog. 
• Vaata tarbimisi ning rõhkusid. 

 

Märkus: Tabel näitab null-tarbimisi ning suuri rõhkusid. See on tingitud asjaolust, et 
tarbimisi ei eksisteeri ning pump töötab shutoff head ümbruses (peaaegu suletuna). 

• Sulge dialoog FlexTable. 
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LoadBuilder 
Järgnevalt kasutad sa klientide tarbimisandmete lisamiseks kahte erinevat meetodit: Nearest 
Node (lähim sõlm) ning Nearest Pipe (lähim toru). Sa lisad tarbimised lähtuvalt inimeste 
arvust, mis on lisatud polügonidele. 

• Vali riba pealt: Tools > LoadBuilder. 
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Lähima sõlme meetod (Nearest Node) 
• Käivita uus juhis, klikkides New nupul. 
• Dialoogis Available LoadBuilder Methods vali Point load data ning seejärel kliki 

Nearest Node. 

 

• Kliki Next, et jätkata. 
• Node Layer rea lõpus kliki (…) nupul, et avada dialoog Select a Layer. 

 

• Vali Junction\All Elements ning kliki nupul Select. 
• Rea Node ID Field juures vali hüpikmenüüst ElementID.  
• Rea Billing Meter Layer lõpus kliki (…) nupul. 
• Vali fail \LoadBuilder\Meters.shp ning kliki Open. 
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Sulle kuvatakse järgmine teavitus: 

 

• Kliki OK. 
• Vali Load Type Field = <none> 
• Vali Usage Field = DEMAND (ühikuga l/s) 
• Vali kastike Use Previous Run. 

 

• Kliki Next, et jätkata. 

Kuvatakse dialoog Calculation Summary. 

Pane tähele, et kogu mõõtmisandmetega seotud tarbimine on 70.76 l/s. 

Märkus: Juhul kui arvutus ebaõnnestub ning kuvatakse teavitus, siis võta üks samm tagasi, 
tühista kastike Use Previous Run ning proovi uuesti. Nüüd võib arvutus võtta veidi rohkem 
aega. 

Need andmed baseeruvad tarbijate mõõtmisandmetel, seega need ei sisalda mõõtmata 
tarbimisi (sh lekkeid). Selleks peame lisama korrektuuri, et neid arvesse võtta. 
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Märkus: Mõõtmata tarbimine on eeldatud suurusega 15%, seega peaksime kogu tarbimise 
korrutama läbi: 1.176 (1/(1-0.15)). 

• Sisesta Global Multiplier = 1.176. 

 

• Kliki Next. 

Sa ei pea midagi muutma dialoogis Results Preview, pane lihtsalt tähele, et sissevoolu 
esitavad sõlmed puuduvad. 

 

• Kliki Next. 
• Dialoogis Completing the LoadBuild Process sisesta kasti Label = NearNode1. 
• Vali New Alternative ning sisesta NearNode. 
• Vali Parent Alternative = Base-Average Daily. 
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• Kliki Finish. 

Veendu, et kokku 102 tarbimist eksporditi kokku. 

 

• Sulge dialoog LoadBuilder Summary ning ka LoadBuilder dialoog. 
• Enne kui lood uue stsenaariumi, vali Analysis > Alternatives. 
• Laienda sektsioonis Demand ning veendu, et seal eksisteerib üks alam alternatiiv 

nimega Base-Average Daily > NearNode. 

 

• Sulge vajadusel Alternatives dialoog ning vali: Analysis > Scenarios. 
• Kliki nupul New ning vali Child Scenario. 
• Nimeta see kui Load_at_Node. 
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• Muuda stsenaariumi parameetreid ning vali alternatiivile: Demand = NearNode. 

 

• Sulge soovi korral stsenaariumite dialoog. 
• Tee stsenaarium Load_at_Node aktiivseks stsenaariumiks. 
• Arvuta mudel: Analysis > Compute. 

Kui kuvatakse dialoog Calculation Summary, pane tähele väärtust Flow Demanded (L/s). 

Võrdle seda tarbimist (83.21 l/s) mõõdetud andmetega (70.76 l/s), erinevus on tingitud 
mõõtmata tarbimiste lisamisest. 

 

• Sulge dialoog Calculation Summary. 
• Ava dialoog FlexTable: Junction ning vaata tarbimisi, mis on sisestatud LoadBuilder 

vahendusel. 

Täida materjali lõpus olev tabel rõhkude osas. 
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Lähima toru meetod (Nearest Pipe) 
Järgnevalt kasutad sa samasid mõõtmisandmeid, kuid rakendad teist meetodit – lähima toru 
meetodit. 

• Riba pealt: Tools > LoadBuilder. 

 

• Kliki New nupul, et käivitada uus LoadBuilder juhis. 
• Vali Point load data ning seejärel Nearest Pipe. 

 

• Kliki Next. 

Sisesta järgmised andmed Model Pipes Data sektsioonis: 

• Pipe Layer: Pipe\All Elements 
• Pipe ID Field: ElementID 
• Load Assignment: Distance Weighted 

Sektsioonis Model Node Layer sisesta: 

• Node Layer: Junction\All Elements 
• Node ID Field: ElementID 
• Use Previous Run: vali kastike 
• Kliki real Billing Meter Layer lõpus oleval (…) nupul ning vali fail Meters.shp (seda 

tegime ka eelmise variandi juures). 
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Sisesta järgmised parameetrid: 

• Load Type Field: <none> 
• Polyline Distribution: Equal Distribution 
• Usage Field: DEMAND (l/s) 

 

• Kliki Next. 

Märkus: Baastarbimine peaks taas olema 70.76 l/s nagu ka enne. 

• Ka nüüd sisesta Global Multiplier = 1.176. 

 

• Kliki Next. 
• Dialoog Results Preview peaks välja nägema alljärgnevalt: 
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• Kliki Next. 
• Sisesta Label = NearestPipe. 
• Vali New Alternative rida ning sisesta uueks nimetuseks: NearPipe. 
• Vali Parent Alternative = Base-Average Daily. 

 

• Kliki Finish. 

Sa peaksid saama teavituse, et kokku eksporditi 102 tarbimist. 

 

• Sulge dialoogid LoadBuilder Summary ning ka LoadBuilder. 
• Vali: Analysis > Alternatives. 
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• Laienda sektsiooni Demand. 

Sa peaksid nägema, et uus alternatiiv NearPipe on loodu Base-Average Daily alla. 

 

• Vali: Analysis > Scenarios ning loo uus alamstsenaarium Base stsenaariumi alla. 
• Nimeta see kui Load_at_Pipe. 

 

• Muuda stsenaariumi Load_at_Pipe parameetreid ning vali Demand = NearPipe. 
• Sulge soovi korral Scenarios dialoog ning tee Load_at_Pipe stsenaarium aktiivseks. 
• Arvuta aktiivne stsenaarium. 

Dialoogis Calculation Summary, pane tähele Flow Demanded väärtust, lähtuvalt tarbimistest 
ning mõõtmata tarbimistest (sh lekked). 

 

• Sulge dialoog Calculation Summary. 
• Ava dialoog FlexTable: Junction ning vaata tarbimise infot, mis sisestati LoadBuilder 

vahendusel. 

Täida materjali lõpus olev tabel. 
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Thiessen Polygon 
Järgnevas näites kasutad sa elanike andmestikku shapefile failist PopulationCensus.shp. Enne 
kui saad seda kasutama hakata, pead sa looma sõlmede ümbrusesse teeninduspiirkonnad. Seda 
saab luua läbi Thiessen Polygon töövahendi. 

• Vali riba pealt: Tools > Thiessen Polygon. 
• Vali Node Layer ning kliki nupul (…). 
• Vali Node Layer: Junction\All Elements. 

 

• Kliki Next. 
• Vali Buffering Percentage ning sisesta kasti 10 kui kasutatav protsent. 

Märkus: Ära sisesta Polygon Boundary layer valikut. 
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• Kliki Next. 
• Kliki Output file rea lõpus oleval nupul (…). 
• Sisesta faili nimeks: \LoadBuilder\Tpoly ning kliki Save. 

 

• Kliki Finish. 

Kui analüüs on lõpetatud, siis naased sa WaterGEMS peaaknasse. 
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• Vali: View > Backgrounds. 
• Kliki nupul New ning vali New File. 
• Vali fail \LoadBuilder\Tpoly.shp. 
• Dialoogis Background Properties for Esri Shapefile, veendu, et Fill Figure kastike 

poleks valitud. 

Märkus: Sa võid muuta Line Color värvi, kui peaksid seda soovima. 

 

• Kliki OK. 
• Lülita faili Meters.shp kuva välja (eemalda linnuke rea eest). 

 

Nüüd saad esmase tagasiside kasutatavate polügonide ning tarbimissõlmede vahel. 
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Tarbimise prognoos elanike arvu järgi 
• Ava uuesti: Tools > LoadBuilder 
• Kliki New nupul, et alustada uut juhist LoadBuilder dialoogis 
• Vali Population/land use data ning seejärel Load Estimation by Population 

 

• Kliki Next 
• Kliki rea Service Area Layer lõpus oleval nupul (…). 
• Vali Tpoly.shp fail, mille me eelnevalt olime loonud. 
• Vali Node ID Field = ElementID 
• Rea Population Layer lõpus kliki nupul (…) ning vali fail PopulationCensus.shp. 
• Vali Population Density Type Field = TYPE ning vali Population Density Field = 

DENSITY, ühikuga pop/ha. 

Tabel täida alljärgnevalt: 

Demand Type Load Density (L/capita/day) 
R1 371 
C 76 
R2 310 
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• Kliki Next. 
• Sisesta lahtrisse Global Multiplier = 1.176, et arvestada 15% mõõtmata tarbimistega 

(sh lekked). 

 

• Kliki Next. 
• Vaata tulemusi ning kliki Next. 
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• Sisesta Label = Pop_LandUse. 
• Vali New Alternative ning sisesta nimeks Pop_LandUse. 
• Vali Parent Alternative = Base-Average Daily. 

 

• Kliki Finish. 
• Sulge LoadBuilder Summary dialoog. Seejärel vaata uut tarbimisandmestikku 

WaterGEMS mudelis. Loo selleks taas uus stsenaarium, mis seda kasutab. 
• Arvuta stsenaarium ning vasta materjali lõpus olevatele küsimustele. 
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Tulemused 
Sõlm Asukoht Near Node  

rõhk (kPa) 
Near Pipe  
rõhk (kPa) 

Population ja Land Use  
rõhk (kPa) 

C_028 Põhi    

D1_078 Ida    

D1_091 Allikas    

 

1. Kuidas saaksid sa tarbimisinfo näiteks aasta 2040 kohta? 

 

 

 

 

2. Miks väikesed muudatused tarbimistes mõjutavad mudeli rõhkusid nii suurel 
määral? 
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Tulemused 
Sõlm Asukoht Near Node  

rõhk (kPa) 
Near Pipe  
rõhk (kPa) 

Population ja Land Use  
rõhk (kPa) 

C_028 Põhi 573 573 728 

D1_078 Ida 366 366 520 

D1_091 Allikas 589 589 741 

 

1. Kuidas saaksid sa tarbimisinfo näiteks aasta 2040 kohta? 

Ilmselt sul pole head tarbimiste infoallikat, mistõttu peaksid kasutama rahvastiku andmeid 
või maakasutust, et leida tarbimisinfo tulevikus. 

 

 

 

2. Miks väikesed muudatused tarbimistes mõjutavad mudeli rõhkusid nii suurel 
määral? 

Tegemist on suletud süsteemiga, kus on küll pump aga mitte mahutit. Seega mistahes 
muutus tarbimises ei mõjuta mitte ainult survekadusid aga ka pumba tööpunkti. 
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