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Mudeli loomine shapefile baasil (WaterGEMS)  
 
Ülesande püstitus 
Selles näites lood sa mudeli shapefile failidest, mis on loodud ArcGIS tarkvaras (ka Autodesk 
ning Bentley kaardirakendust omavad tarkvarad võimaldavad shapefile luua). Seejärel 
analüüsid sa mudelit. Lisaks vaadatakse ka erinevaid töövahendeid, kuidas mudeli elemente 
kiiremini leida. 
 

Peale selle näite läbimist oskad sa: 

• Mudelit üles ehitada läbi ModelBuilder töövahendi 
• Kasutada Network Navigator töövahendit, et leida mudeli elemente kiiremini 

Ava uus fail WaterGEMS tarkvaras. Veendu, et uues failis kasutatakse System International 
ühikutesüsteemi (menüüst Tools > Options). 

• Käivita ModelBuilder töövahend: Tools > ModelBuilder. 

Märkus: ModelBuilder on sisuliselt dialoogide jada, milles tehtavad muudatused jäetakse 
meelde nö seadetegrupina, millele pääsed edaspidi ligi samast dialoogist. 

 

• Kliki nupul New, et käivitada uus dialoogide jada. 
• Vali Select a Data Source type > Esri Shapefiles. 
• Kliki Browse nupul, mille leiad rea Select your Data Source lõpust. 
• Kataloogist \ModelBuilder vali CTRL klahvi all hoides järgmised failid: Pipes_1.shp, 

Junctions_1.shp, ning Tanks_1.shp. 
• Kliki Open, et kinnitada valik ModelBuilder tarvis. 

Pane tähele, et dialoogi vasakus sektsioonis on nüüd 3 gruppi andmeid. 

Märkus: Iga grupp omab väikest kastikest nimetuse ees, mille kaudu saad selle sisse- või 
välja lülitada. 

• Vali kastike Show Preview ning sulle kuvatakse andmete tüübid, mida igas tabelis 
hoitakse. Eelvaade kuvatakse paremas sektsioonis. 

• Vali Tanks-1 ning pane tähele, et väljad: ELEV_MAX ning ELEV_MIN ei oma 
andmestikku; samas ELEV_BASE omab numbrilist väärtust. 
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• Kliki Next nupul, et liikuda edasi järgmise sammu juurde. 
• Ühikusüsteemina Coordinate Unit vali m (meeter). 
• Veendu, et valikud Create nodes if none found at pipe endpoint ning Establish 

connectivity using spatial data pole valitud. 

 

• Kliki Next. 

Järgnevalt määrad sa elementide loomise/eemaldamise ning uuendamise seaded. 

• Jäta vaikimisi väärtused nagu on näha allolevas dialoogis. 
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• Kliki Next. 
• Lisaseadete lehel jäta vaikimisi väärtused nii nagu näidatud alloleval pildil. 

 

Märkus: Juhul kui sa impordiksid seda andmestikku olemasolevasse mudelisse, siis saaksid 
andmed importida olemasolevasse (aktiivsesse) stsenaariumisse või luua uus 
alamstsenaarium. Uus stsenaarium ning alternatiivid nimetatakse automaatselt kui Created by 
ModelBuilder ühes kuupäeva ning kellaja märkega, mil see loodi. Juhul kui alternatiivis 
muudatust pole vaja teha, siis ei looda ka alamalternatiivi selle konkreetse juhtumi korral. 

• Kliki Next. 

Järgnevalt oled sa ModelBuilder selles sektsioonis, kus ühendad omavahel Esri Shapefile 
atribuudid ning WaterGEMS elementide parameetrid. 
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• Vali Junctions_1 (vasakult paanilt) ning seejärel paan Settings paremas sektsioonis. 
• Vali Table Type = Junction. 

Märkus: Seejärel pääsed ligi algfaili kõikidele väljadele. 

• Vali Key Fields = LABEL. 
• Jäta X Field ning Y Field sättele <auto>, kuna koordinaadid loetakse automaatselt 

algfailist. 
• Veeru Field all, kliki ELEVATION, seejärel vali kõrvalolevast sektsioonist Property > 

Elevation, ühikuks vali Unit = m. 

 

• Vali Pipes_1 (vasakult paanilt) ning vali Table Type = Pipe. 
• Vali Key Fields = LABEL. 
• Jäta Start ning Stop väljad kui <none> kuna need väljad on seotud ruumilise 

seotavusega (Spatial Connectivity), mis sai seadistatud eelmises dialoogis. 
• Vali veerus Field, väli DIAMETER ning Property menüüst vali sinna Diameter. 
• Ühikuks vali Unit = mm. 
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• Vali rida Tanks_1 (vasakult paanilt), ning vali Table Type = Tank. 
• Vali Key Fields = LABEL. 
• Vali veerus Field, väli DIAMETER ning Property menüüst vali sinna Diameter. 
• Vali ühikuna Unit = m. 
• Vali ELEV_BASE rida ning seo see parameetriga Property: Elevation (Base), ühikuks 

vali Unit = m 

 

• Kliki Next. 
• Järgmises dialoogis vali küsimusele Would you like to build a model now? = Yes. 

Teised seaded jäävad nii nagu on. 
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• Kliki Finish. 

Märkus: Juhul kui kuvatakse allolev teavitus, siis loe see läbi ning vasta Yes. 

 

Peale ModelBuilder käivitust ütleb ModelBuilder Summary dialoog, et osasid torusid polnud 
võimalik luua, kuna puudub vajalik topoloogia. 
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• Vali paan Messages ning sa näed, et torud ei ole leidnud sobivaid algus- ning 
lõppsõlmi. 

 

• Sulge ModelBuilder Summary dialoog. 

Eelmise vea parandamiseks läheme tagasi ModelBuilder dialoogi ning parandame topoloogia 
lähtuvalt sõlmede läheduse printsiibist. 

• ModelBuilder dialoogis kliki nupul Duplicate, et teha olemasolevast lingist koopia. 
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• Veendu, et koopia ModelBuilder(1) on esile tõstetud, vali Edit nupul, et kuvada uuesti 
redigeerimise dialoog. 

• Kliki Next, kuna Data Source väljad on juba täidetud. 

Märkus: Siin dialoogis määrad sa üheselt ModelBuilder moodulis, kuidas andmetega 
ühendus luuakse. Kui see kastike on välja lülitatud, siis pead määrama järgnevates 
dialoogides Field Mapping: Pipes – Start/Stop väljad. 

• Dialoogis Specify Spatial and Connectivity Options vali kastike Create nodes if none 
found at pipe endpoint. 

• Vali ka kastike Establish connectivity using spatial data ning sisesta Tolerance = 0.03 
m. 

 

• Kliki Next kuniks jõuad sammuni Create Model Now? 
• Vali Yes, et mudel kohe luua. 
• Kliki Finish ning kui kuvatakse sünkroniseerimise teavitus, siis vasta Yes, et jätkata. 

Sel korral uuendati 657 toru. 
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• Sulge ModelBuilder Summary ning ModelBuilder dialoog. 
• Kliki Yes kui kuvatakse järgmine dialoog: 

 

• Mudeli kontrollimiseks vali esmalt: View > Zoom and View > Zoom Extents. 

 

Kontrolli ModelBuilder poolt loodud mudeliinfot. 
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• Vali: View > Selection and Query > Selection Sets. 

Märkus: Pane tähele, et loodud on 2 valikugruppi. 

 

• Vali üks neist valikugruppidest ning kliki Select in Drawing nupul. 
• Sulge Selection Sets dialoog, kui oled lõpetanud ning vali: Report > Element Tables > 

Junction. 

Märkus: Sa peaksid nägema maapinna kõrgusmärke, mis leiti lähtefailidest. 

• Sorteeri Elevation kasvavalt. 

Pane tähele, et kokku kaheksal sõlmel pole hetkel maapinna kõrgusmärki. 

 

• Sulge Junction tabel ning vali: Report > Element Tables > Pipe. 

Vaate andmeid tabelis. 

 

• Sulge Pipe tabel ning vali: Report > Element Tables > Tank. 
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Märkus: Kui sa kontrolliksid teisi tabeleid, nagu näiteks Reservoir või PRV, siis leiaksid, et 
need on tühjad, kuna neid elemente polnud lähteandmetes olemas. 
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Mudeli andmete sisestamine 
Nüüd, kus meil on mudel üles ehitatud, sooviksime seda arvutada, kuid esmalt on vaja veel 
andmeid sisestada. 

• Salvesta mudelifail: File > Save As. 
• Nimeta see fail kui: ModelBuilder_lahendus.wtg. 

Kui sa püüaksid oma mudelit hetkel käivitada, siis see ei õnnestuks, kuna mahutis pole 
sisestatud algset veetasapinda. 

• Vali: View > FlexTables. Tee topelt klikk Tank Table peal. 
• Mõlema mahuti osas sisesta järgmine info: 

o Elevation (Minimum) (m): 445.01 
o Elevation (Initial) (m): 449.58 
o Elevation (Maximum) (m): 451.10 

 

• Sulge FlexTable: Tank Table dialoog. 

Mäletatavasti sisestasime sõlmede kohta vaid kõrgusmärgid (ModelBuilder vahendusel). 
Seega mudelis pole ühtegi tarbimist. 

• Vali: Components > Common > Demand Control Center. 

Märkus: Juhul kui kuvatakse teavitus mudeli olulisest muudatusest, kliki Yes. 

• Kliki New nupu allapoole suunatud noolel ning vali Initialize Demands for All 
Elements. 

 

• Parem klikk Demand (Base) veeru päisel ning vali Global Edit. Sea kõik tarbimised 
väärtusele 0.13 l/s. 
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• Kliki OK. 

 

• Kliki Close, et väljuda Demand Control Center dialoogist. 
• Kliki Compute nupul, et arvutada mudel. Peale arvutust kuvatakse Calculation 

Summary. 
• Sulge Calculation Summary dialoog. 
• Vali: Report > Element Tables > Junction. 
• Vaata sõlmede tabelis veergu Pressure. 
• Järjesta Pressure veerg kasvavalt. 

Pane tähele ühte sõlme, A-311, kus on selle maapinna tõttu väikesed vabasurved. 

 

• Kliki Zoom To nupul, et liikuda sõlme A-311 juurde. 

Pane tähele, et see sõlm asub mahuti Hillside läheduses. 
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• Taasta FlexTable: Junction Table dialoog ning sorteeri Pressure veerg kahanevalt. 

 

Märkus: Pane tähele, et osade sõlmede rõhud on väga kõrged, kuna nendele pole lisatud 
maapinna kõrgusmärki. 

• Lisa puuduolevad kõrgusmärgid alljärgneva tabeli põhjal: 

Label Elevation (m) 
J-1 396.55 
J-2 396.85 
J-3 397.15 
J-4 397.46 
J-5 397.76 
J-6 398.07 
J-7 398.37 
J-8 398.68 

 

Hoiatus: Pane tähele, et sisestad õigetele sõlmedele õige kõrguse. 

• Vähenda dialoogi FlexTable: Junction Table dialoogi ning arvuta mudel uuesti. 
• Sulge dialoog Calculation Summary ning taasta dialoog FlexTable: Junction Table. 
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Täida materjali lõpus olev tabel. 
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Network Navigator 
Järgnevalt kasutad sa Network Navigator töövahendeid, et kontrollida ModelBuilder poolt 
loodud mudelit. 

• Vali riba pealt: View > Selection and Query > Network. 

 

Esmalt kontrollime torusid, mis pole sõlmedega ühendatud. 

• Kliki nupul Select ning vali Network Review > Pipe Split Candidates. 
• Sisesta Tolerance = 6.1 m. 

 

Märkus: Vajadusel tee parem klikk Tolerance (m) väljal ning vali Units and Formatting, et 
muuta esituse täpsust. 

• Kliki OK. 

Märkus: Kuvatakse neli sõlme, mis langevad valitud kriteeriumi alla. 
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• Vajadusel muuda suurenduse faktorit: Zoom: 75% ning kliki A-663 real, et liikuda 
selle sõlme juurde. 

• Kontrolli sarnaselt igat sõlme, mis on Network Navigator dialoogis kuvatud. 

 

Iga konkreetse juhtumi korral peaksid sa tegelikkust kontrollima lähtejooniste kaudu, kas 
ühendus ka reaalselt eksisteerib või mitte. Juhul kui tegemist on veaga, siis pead otsustama, 
kas viga parandada vaid mudelis või ka GIS süsteemis ning seejärel teostama uue impordi. 

• Network Navigator dialoogis vali Select: Network Review > Nodes in Close Proximity. 
• Sisesta Tolerance = 9.1 m ning kliki OK. 

 

Märkus: Üks sõlm vastab eelseadistatud kriteeriumile. 
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• Kasuta taas Zoom To nuppu, et kontrollida olukorda. 

 

 

Märkus: Juhul kui kaks sõlme on üksteisele liiga lähedal, siis kuvatakse Network Navigator 
dialoogis neist vaid üks. Lisainfot omamata on keerukas teada saada, kas need sõlmed peavad 
olema ühendatud. 

• Vajadusel nihuta Network Navigator dialoogi, et näeksid joonise töövahendeid. 
• Joonise aknas vali Junction lisamise töövahend ning lisa üks uus sõlm joonisele. 
• Nimeta see kui J-9. 

 

 
• Dialoogis Network Navigator vali Select > Network Review > Orphaned Nodes. 
• Dialoogis kuvatakse vaid üks sõlm, nimetusega J-9. 
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• Sulge Network Navigator. 
• Kustuta sõlm J-9. 
• Salvesta oma fail ning vasta materjali lõpus olevatele küsimustele. 

Märkus: Vajadusel käivita mudel uuesti.  
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Näite küsimused 
1. Sisesta allolevasse tabelisse sõlmede rõhud (kPA): 

Sõlm Pressure (kPa) 
A-26  

A-162  

J-8  

 

2. Mõned algfaili väljade osas ei loodud ühendust WaterGEMS atribuutidega. Miks? 

 

 

 

 

3. Andmed oleks võinud eksportida ka standardsesse MS Access faili ja seejärel 
importida WaterGEMS tarkvarasse. Miks see pole aga hea idee? 

 

 

 

 

4. Kuidas oleksid veel saanud mahuti infot mudelisse sisse tuua (lisaks käsitletud 
variandile, kus sisestasid selle info tabelite baasil)? 

 

 

 

 

5. Selgita tolerantside erinevusi, mis on leitavad ModelBuilder dialoogi Specify Spatial 
Options sektsioonis ning Network Navigator dialoogis. Üldjuhul, kumb peaks olema 
väiksem? 

 

 

 

  



WATER | Mudeli loomine shapefile baasil (WaterGEMS) | Raido Puust | 2024 21/21 
 

Näite küsimused 
1. Sisesta allolevasse tabelisse sõlmede rõhud (kPA): 

Sõlm Pressure (kPa) 
A-26 262.7 

A-162 495.5 

J-8 497.8 

 

2. Mõned algfaili väljade osas ei loodud ühendust WaterGEMS atribuutidega. Miks? 

Neid väljasid polnud mudeli loomiseks vaja. 

 

 

3. Andmed oleks võinud eksportida ka standardsesse MS Access faili ja seejärel 
importida WaterGEMS tarkvarasse. Miks see pole aga hea idee? 

Kasutades näites valitud meetodit saame mudelisse importida ka torude murdepunkte ning 
topoloogia jääb automaatselt alles. 

 

 

4. Kuidas oleksid veel saanud mahuti infot mudelisse sisse tuua (lisaks käsitletud 
variandile, kus sisestasid selle info tabelite baasil)? 

Sa oleksid võinud luua ka lisa lähtefaili, kust oleksid siis omakorda andmed sisse lugenud 
ModelBuilder lingi kaudu. 

 

5. Selgita tolerantside erinevusi, mis on leitavad ModelBuilder dialoogi Specify Spatial 
Options sektsioonis ning Network Navigator dialoogis. Üldjuhul, kumb peaks olema 
väiksem? 

ModelBuilder dialoogis, kui tolerants on täidetud, siis liidetakse sõlmed automaatselt, 
samas Drawing Review dialoogis antakse kasutajale võimalus redigeerida sõlmi. Seega 
peaksime ModelBuilder tolerantse hoidma üldjuhul väiksematena, sest Drawing Review 
võimaldab topelt-kontrollina vaadata, kas mõni teine ühendus ei jäänud tegemata, kuna 
ModelBuilder dialoogis kasutati liiga väikest väärtust. 
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