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Veekvaliteedi modelleerimine (EPANET) 

EPANET näiteülesanne (baseerub Help > Tutorial näitel, muudetud parameetreid!) 

Joonistada võrguskeem järgides joonist 1. Võrk koosneb reservuaarist, kust vesi pumbatakse ringvõrku. 
Samuti on lisatud üks mahuti, võrgu kompenseerimiseks. 

 

Joonis 1. 
 
Projekti ettevalmistamine 
Esmalt tuleb meil luua EPANET 2.0 uus projekt, ja kontrollime, et kindlad vaikimisi väärtused oleksid 
määratud vastavalt meie ülesandele. 

1. Ava EPANET 2.0 (Windowsi programmi menüüst) 
2. Vali File > New, misjärel luuakse uus projekt. 
3. Vali menüüst Project > Defaults ja avatakse dialoogiaken Defaults. 
4. Paanil ID Labels, tühista kõik eesliite määrangud , mis puudutavad elemente. Veerg ID Prefix 

on seega tühi, välja arvatud viimane rida ID Increment, kuhu sisesta 1. Viimati sisestatud 
väärtus tähendab, et elementide lisamisel joonisele, kasvatatakse elemendi ID tähist 1 astme 
võrra. 

5. Paanil Hydraulics real Flow Units vali LPS (see on süsteemiühik, mida kasutatakse arvutustes 
ja ka väärtuste sisestamisel – lühend liitrit/sekundis) ja reale Headloss Formula vali D-W, mis 
tähistab rõhukadude arvestamise valemit (antud juhul siis Darcy-Weisbach). 

6. Kliki dialoogiakna alaservas OK selle sulgemiseks ja väärtuste kinnitamiseks. 

Märkus: Kui sa soovid viimati sisestatud muudatusi ka järgnevates projektides kasutada, kliki nupul 
Save, enne kui sulged dialoogiakna. 
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Kaardistuse seaded 
Järgnevalt määrame mõned parameetrid, mis esitavad elementide lisamisel kaardile, koheselt näha 
nende ID numbrit (lisaks sümbolitele). 

1. Menüüst View > Options, avaneb dialoogiaken Map Options. 
2. Vali alagrupp Notation, tähista linnukesega väljad Display Node IDs ja Display Link IDs. Teised 

jäta märkimata. 
3. Vali alagrupp Symbols ja tähista kõik väljad siin sektsioonis. 
4. Kliki OK nuppu, muudatuste salvestamiseks ja dialoogiakna sulgemiseks. 

Enne joonestama asumist, peame määrama ka kaardi mõõtmed. 

1. Menüüst View > Dimensions avab dialoogiakna Map Dimensions. 
2. Järgneva näite jaoks pole vaja vaikimisi väärtusi muutma hakata. 

 
Võrgu sõlmede joonestamine 
Nüüd võime alustada võrguskeemi joonestamisega. 

1. Esmalt lisame reservuaari, klikkides ikoonil , tööriistapaanil Map Toolbar : 

 

(Kui see tööriistapaan pole nähtaval, vali menüüst View > Toolbars > Map). Seejärel kliki 
joonisel soovitud kohas, kuhu reservuaari paigutada. 

2. Edasi lisame sõlmed. Kliki nupul  , tööriistapaanil Map Toolbar ja kliki vastavalt joonisele 
sõlmed tähistusega 2 ... 7.  

3. Lisaks joonestame ka mahuti. Kliki ikoonil , ja lisa kaardil näidatud asukohta vastav 
mahuti. 

Pane tähele, kuidas elementide nimetusi kasvatakse vastavalt eelseadistustele (ID Labels). 

 
Võrgu torude joonestamine 
Järgmisena lisame torud. 

1. Alustame toruga Toru 1, mis ühendab sõlmi Sõlm 2 ja Sõlm 3. 

a. Kliki nupul  , tööriistapaanil Map Toolbar. 
b. Kliki hiirega sõlmel Sõlm 2 ja seejärel sõlmel Sõlm 3. 
c. Järgi, kuidas punktiirjoonena tähistatakse tulevast toru, kui sa liigu Sõlm 2-lt Sõlm 3-e 

suunas. 

2. Korda sama protseduuri torude 2 kuni 7 tarvis. 
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3. Toru 8 on kõverjoon. Selle joonestamiseks, kliki esmalt sõlmel Sõlm 5. Seejärel, kui sa liigud 
hiirega Sõlm 6 suunas, kliki neis punktides, kus soovid muuta suuna kuju, saamaks soovitud 
toru paigutust. Lõpeta protsess, vajutades Sõlm 6-l. 

4. Lõpetuseks lisame veel ka pumba, klikkides ikoonil  , valides esmalt sõlme Sõlm 1 ja 
seejärel Sõlm 2. 

 
Kaardile teksti lisamine 
Viimane osa meie võrgu joonestamisprotsessis on lisada mõned kirjeldavad teksti väljad. 

1. Kliki ikoonil  , tööriistapaanil Map Toolbar ja kliki reservuaari (Sõlm 1) läheduses. Avaneb 
tekstikast, kuhu trüki ALLIKAS ja vajuta ENTER klahvi. 

2. Kliki seejärel pumba läheduses, ja sisesta tekst PUMP, sama tee ka mahuti juures, trüki 
MAHUTI. 

3. Kliki ikoonil  , tööriistapaanil Map Toolbar, muutes kaardil tehtava objektivaliku režiimi 
(eelnevalt oli tekstilisamise režiimis). 

 
Objektide ümberpaigutamine 
Praeguseks hetkeks peaks meil võrguskeem olema paigas. Sinu võrk peaks välja nägema selline, nagu 
on näidatud joonisel 1. Kui sõlmed on nihkunud, või soovid nende asukohta kaardil muuta, tuleb sul 
vastav sõlm esmalt valida, ja seejärel lihtsalt hiirega vedada see teise kohta. Ka tekstivälju saab 
analoogselt ümber paigutada. 

Painutatud toru 8 asetust saab muuta järgmisel viisil: 

1. Esmalt vali toru, klikkides hiirega torul 8, seejärel kliki nupul  , tööriistapaanil Map Toolbar 
muutmaks kaardi esitamise režiim lingipõhiseks.  

2. Vali välja soovitud murdepunkt, mille asukohta soovid parandada, ja tiri see hiirega teise kohta 
(hoides vasakut hiireklahvi samas all). 

3. Vajadusel saab olemasolevatele linkidele teha lisamisi või ka neid kustutada, klikkides hiire 
parema klahviga kaardil ja valides avanevast kiirvalikumenüüst soovitud ülesanne. 

4. Kui oled objektide ümberpaigutamisega ühele pool saanud, vajuta taas nupule  , 
naasmaks objektivaliku režiimi. 
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Parameetrite sisestamine 
Peale objektide lisamist, omistab EPANET neile mingid vaikimisi väärtused (parameetrid). 
Olemasolevate parameetrite muutmiseks peame selle objekti valima Property Editor aknasse (vt. 
allolevat joonist). Vastava akna kuvamiseks on mitu erinevat võimalust. Kui vastav aken on juba avatud, 
võid lihtsalt klikkida objektil kaardil ning vastava seaded kuvatakse avatud aknas (objekti võid valida ka 
läbi Browser akna, paani Data ja seejärel valides hüpikmenüüst vastava objektigrupi saad allolevast 
nimekirjast valida soovitud objektil endal).  

 

Kui parameetrite aken pole avatud, võid selle avamiseks teha ühte alljärgnevat: 

• topelt-klikk kaardil soovitud objektil 
• parem klikk objektil, valides Properties kiirvalikumenüüst 

• vali objekt paanilt Data, olles Browser aknas. Ning peale seda nupul  (Browser’s Edit). 
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Sõlmede parameetrite sisestamine 
Sõlmed meie näidisvõrgus omavad järgmisi parameetreid: 

 

Sõlm 
Elevation (m) Demand (lps) 

(Maapind)* (Tarbimine) 

1 214* 0 

2 214 0 

3 217 9.46 

4 214 9.46 

5 198 12.62 

6 214 9.46 

7 214 0 

8 253 0 

* Sõlm 1 (reservuaar) juures on vastav parameeter Total Head 

Valime näiteks sõlme Sõlm 2 parameetrite aknasse. Kas siis tehes vastaval elemendil topelt-klikk, või 
valides Browser aknas ikooni Browser Edit. 

Sisesta selle sõlme jaoks väärtused maapinna (Elevation) ja tarbimise (Demand) kohta. Sa võid 
kasutada lahtrite vahel liikumiseks klaviatuuri klahve Up ; Down või lihtsalt hiirega osutades järgmisel 
väljale. Peale ühe sõlme väärtuste sisselöömist, võime valida lihtsalt teise sõlme (meil pole vaja sulgeda 
parameetrite akent, vastav objekt vahetub seal aknas automaatselt) kaardil, kas siis hiirega või 
klaviatuurilt vajutades Page Down ; Page Up klahvi, mis viib meid vastavas objektigrupis kas siis 
eelneva või järgneva elemendi juurde. 

Reservuaari (Sõlm 1) taris sisestame maapinnaks (koos võimaliku lisasurvega) (Total Head) : 214 m. 
Mahuti jaoks (Sõlm 8) märgime: Elevation = 253 m; algne veetase Initial Level = 1 m; maksimaalne 
veetase Maximum Level = 6 m; ja mahuti diameetriks Diameter = 18 m. 
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Torude parameetrite sisestamine 
Torud meie näidisvõrgus omavad järgmisi parameetreid: 

 

Toru Length (m) 
Diameter 
(mm) 

(Pikkus) (Läbimõõt) 

1 915 356 

2 1525 305 

3 1525 203 

4 1525 203 

5 1525 203 

6 2135 254 

7 1525 152 

8 2135 152 

Ja torude karedustegurid on (Roughness) on kõik 0.3 mm (terastoru). Analoogselt sõlmede 
sisestamisele, teeme sama torude juures, lisame esitatud parameetrid. 

 
Pumba graafiku lisamine 
Pumba jaoks peame lisama pumbagraafiku (tõstekõrgus vs vooluhulk). 

1. Valime pumba (Toru 9) parameetrite seadmise aknasse, ja sisestame reale Pump Curve 
väärtuse 1. 

2. Nüüd loome vastava kõvera nimega 1. Brauseri aknas (Browser) valime paani Data ja seejärel 

hüpikmenüüst valime Curves. Klikime nupul  . Uus graafik nimega Curve 1 lisatakse meie 
andmebaasi ja seejärel kuvatakse selle graafiku seadmise dialoogiaken Curve Editor. 

3. Sisestame pumbale järgmise tööpunkti: Flow = 37.83 l/s ja Head = 46 m. EPANET loob 
automaatselt ühe punkti alusel vastava pumba graafiku. Esitatakse ka pumba graafiku valem. 

4. Kliki OK nupul, parameetrite salvestamiseks. 

 
Projektide avamine ja salvestamine 
Peale võrguskeemi loomist, tasub meelde tuletada ka selle salvestamist, et tehtud tööd enam kordama 
ei peaks (tegelikult võiks seda muidugi sagedamini teha!). 

1. Menüüst File > Save As. 
2. Avanenud dialoogiaknasse Save As vali asukoht ja sisesta nimi, millega soovid võrku 

salvestada. Faili lõppu lisatakse automaatselt faililaiend .net. 
3. Kliki OK projekti salvestamiseks. 
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Projekti info on salvestatud spetsiaalses formaadis. Kui sa soovid võrgus olevat infot talletada teksti 
põhisena (nii et saad seda avada mõnes tekstiredaktoris, nt Notepad), vali menüüst File > Export > 
Network. 

Faili avamiseks vali menüüst: File > Open. 

 
Kindla ajahetke analüüsi arvutamine (Single Period Analysis) 
Meil on kõik andmed sisestatud selleks, et saaksime läbi viia oma esimese hüdraulilise arvutuse 
(fikseeritud ajahetkel). Arvutusprotsessi käivitamiseks vali menüüst Project > Run Analysis (või kliki 

ikoonil  ). 

Kui arvutus ebaõnnestub, avaneb dialoogiaken Status Report, mis esitab võimalikud probleemid. 
Arvutuse õnnestumise korral, saad vaadata lahendustulemusi erinevatel viisidel. Proovi mõnda 
alljärgnevast: 

• Vali Browser aknas paan Map ning sektsioonis Nodes vali hüpikmenüüst Pressure. See esitab 
skeemil sõlmede rõhud värvikoodis, vastavalt määratud legendile, mis peaks ilmuma samuti 
tööaknasse. Kui sa seda ei näe, vali menüüst View > Legends > Node (või tee parem klikk 
kaardil, vali Node Legend ilmuvast kiirvalikumenüüst). Kui sa soovid värvikoodi intervalle 
muuta, parem klikk legendil ning muuda vastavaid väärtusi dialoogiaknas Legend Editor. 

• Ava parameetrite aken (topelt klikk mistahes sõlmel või torul) ja vaata arvutatud parameetreid 
tabeli lõpus. 

• Kui sa soovid vaadata tulemusi tabeli kujul, vali menüüst Report > Table (või kliki ikoonil ). 

 
Tarbimisgraafiku lisamine 
Võrgu töö põhjalikumaks analüüsiks tuleks sisestada ajafaktor tarbimistele, mis näitab, kuidas 
tarbimine päeva lõikes erineb (erineval tunnil). Selles näites kasutame ajasammuna 6 tundi. See 
tähendab, et tarbimine muutub ööpäeva lõikes neljal korral. (Vaikimisi väärtus on tavaliselt 
veevõrgutarkvaras 1, mis tähistab 24-tunni graafikut). Tarbimisgraafiku ja analüüsi pikkuse 
määramiseks teeme järgmist: 

1. Vali Browser aknas paanilt Data hüpikmenüüst Options ja seejärel Times.  

2. Kliki Browser aknas ikoonil  , misjärel avaneb seadete aken Times Options (kui see juba 
avatud pole). 

3. Sisesta reale Pattern Time Step = 6. 
4. Sisesta reale Total Duration = 72 (3 ööpäeva). 

 
Tarbimisgraafiku loomine 
Tarbimisgraafiku loomiseks toimi alljärgnevalt: 

1. Vali Browser aknas paanilt Data hüpikmenüüst Patterns. 

2. Kliki ikoonil  (või vajuta klaviatuurilt Insert klahvi). Luuakse uus graafik 1 ja avatakse 
dialoogiaken Pattern Editor. 
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3. Sisesta kordajate väärtusteks: 0.5; 1.3; 1.0; 1.2; ajaväärtustele 1 kuni 4. 
4. Kliki OK dialoogiakna sulgemiseks. 

Neid kordajaid kasutatakse vooluhulga muutmiseks igal määratud ajahetkel. Kuna meie teostame 
hetkel 72 tunni analüüsi, siis kasutatakse sama graafikut iga 24-tunnise tsükli järel. 

Me peame vastava loodud tarbimisgraafiku sisestama ka meie tarbimissõlmedele, parameetri rea 
Demand Pattern kasti. Kuna tegemist on antud juhul ühe sama graafikuga, siis oma töö lihtsustamiseks 
võime ümber defineerida EPANET-i vaikimisi graafiku seade. Selleks valime Browser aknas paanilt Data 
hüpikmenüüst Options > Hydraulics ja muudame real Default Pattern vastava seade oma loodud 
graafiku nimele, mis peaks olema 1. Sellisel juhul kasutab tarkvara vaikimise tarbimisgraafikuna igas 
süsteemi sõlmes vastavat graafikut 1. 

 
3-ööpäevase analüüsi sooritamine 
Sellega oleme valmis käivitama analüüsi, valides menüüst Project > Run (või klikkides ikoonil ). 
Ajaskaalaga analüüside tulemuste vaatamiseks on veel mõned lisavõimalused: 

• Kasuta kerimisnuppu Browser akna paani Map sektsioonis Time kuvamaks tulemusi erinevatel 
kellaaegadel. 

• Kasuta sektsioonis Time olevaid nuppe, kas siis jätkuva animatsiooni jälgimiseks (kliki ikoonil 

) või selle peatamiseks nupul  . 
• Loo mistahes sõlme või toru kohta ajagraafik. Näiteks, jälgimaks, kuidas veetase muutub 

mahutis ajalõikes: 

1. Kliki mahutil. 

2. Vali menüüst Report > Graph (või kliki ikoonil  ), misjärel kuvatakse dialoogiaken 
Graph Selection. 

3. Vali dialoogiaknas, vasakul pool sektsioonis, Time Series. 
4. Vali Head (veetase) kui muutuvaks suuruseks (Parameter). 
5. Kliki OK oma graafiku esitamiseks. 

Jälgi, kuidas veetase muutub ajas perioodiliselt (3 x 24 tundi). 
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Veevanuse hindamine 
Üks lihtsamaid veekvaliteedi näitajaid on veevanuse hindamine võrgus. Vaadatakse seda üle mingi 
ajaperioodi. Analüüsi teostamiseks toimi alljärgnevalt: 

1. Vali Browser aknas paanilt Map hüpikmenüüst Options ja seejärel Quality. 

2. Kliki Browser aknas ikoonil  , kuvatakse dialoogiaken Quality Options. 
3. Vali real Parameter hüpikmenüüst väärtus Age. 

Käivita analüüs uuesti. Vaata tulemust esmalt kaardil, valides Browser aknas paani Map ja seal 
sektsioonis Nodes hüpikmenüüst Age. Vaatame ka mõnda graafikut. Loo graafik taas mahuti lõikes, 
sedakorda veevanuse hindamiseks 72 tunnisel perioodil. Nagu graafikult näha, ei saavuta mahuti 3 
ööpäeva lõike perioodilist käitumist. Selleks suurendame simulatsiooni aega 240-le tunnile ja asetame 
mahuti parameetrite aknas Initial Quality väärusele 60 (tundides). Loome uuesti graafiku. 

See lõpetab ülesande. 
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